Comment mettre à jour un plugin obsolète lors de la sortie d’une nouvelle version de Firefox (ou Thunderbird) ?

closeCet article a été publié il y a 2 ans 7 mois 18 jours, il est donc possible qu’il ne soit plus à jour. Les informations proposées sont donc peut-être obsolètes.
  • En installant Ubuntu 12.04 LTS Precise Pangolin, j’ai automatiquement bénéficié de la version 11.0 de Firefox et, lorsque j’ai voulu télécharger le plugin de contrôle parental  Procon Latte, j’ai obtenu le message suivant :

Comme il était hors de question que j’ouvre une session à mes enfants sans ce plugin, j’ai choisi non pas de l’installer mais de le télécharger en faisant un clic droit et en choisissant « Enregistre la cible du lien sous… »  afin de le modifier pour qu’il fonctionne dans cette version de mon navigateur

Une fois le fichier téléchargé, j’ai modifié l’extension .xpi en .zip

afin de pouvoir l’ouvrir avec mon gestionnaire d’archives.

J’ai ensuite ouvert le fichier install.rdf avec mon éditeur de texte (Gedit).

pour modifier le 9.0 de la ligne surlignée qui indique la version maximum de validité de l’extension par 12.0

J’ai enregistré ma modification et ai renommé le dossier .zip en .xpi puis, je suis allé dans la rubrique Outils > Modules complémentaires de Firefox afin d’installer manuellement le plugin modifié.

Il ne restait plus qu’à indiquer le chemin du fichier .xpi pour lancer l’installation…

… et enfin redémarrer Firefox.

  • Si vous ne faites pas une nouvelle installation de votre distribution mais une mise à niveau ou si vous avez conservé vote home précédent, vous pouvez être confronté à une autre situation puisque votre plugin sera sans doute déjà présent.


Dans ce cas de figure, il suffit d’aller chercher le fichier .xpi de l’extension dans votre home : ~/.mozilla/firefox/99blabla.default (votre profil)/extensions et d’appliquer la même procédure que ci dessus puis de relancer Firefox afin que cette modification soit prise en compte.

Amusez vous bien.

Source : Gizmo’s freeware

8 réponses à Comment mettre à jour un plugin obsolète lors de la sortie d’une nouvelle version de Firefox (ou Thunderbird) ?

  • Sergio dit :

    Pas la peine de renommer le .xpi en .zip : Il suffit de faire, clic-droit « Ouvrir avec » et choisir son gestionnaire d’archives préféré…

    Personnellement, je fais tout (ou presque…) en ligne de commande.

  • Christophe dit :

    C’est toujours bien de rappeler cette petite astuce, bien pratique, même si elle à parfois ses limites.

    J’ai été obligé de cesser de ressusciter une extension que je « trainais » depuis 4 ans : http://catarina.free.fr/index.php?pages/Bloc-notes-Google-avec-Firefox-3.5

  • Kontre dit :

    J’ai encore plus simple, il suffit d’installer un addon : Addon Compatibility Reporter (https://addons.mozilla.org/fr/firefox/addon/add-on-compatibility-reporter/?src=api).
    Il permet de charger les add-ons périmés et de reporter si ceux-ci fonctionnent toujours ou non.
    Deux avantages donc : pas besoin de refaire la manip à chaque mise à jour de firefox ou des add-ons, et ça aide la communauté à savoir ce qui fonctionne encore ou non !

  • Jean dit :

    Normalement à partir de Firefox 10, les modules sont compatibles par défaut, à condition d’être prévus pour Firefox >= 4, et de ne pas avoir de modules binaires. C’est le cas pour l’add-on de l’exemple.

    Il suffit donc en principe de cliquer sur le bouton « Installer quand-même », sans rien modifier au xpi.

    Pour cette raison aussi, l’add-on « Addon Compatibility Reporter » ne modifie plus le mode de compatibilité de Firefox, il ne sert vraiment plus qu’à ce que son nom indique : signaler les problèmes de compatibilité.

  • Atom dit :

    Je ne vois pas de réel remerciement dans les commentaires. Et cette astuce n’est pas évidente pour tous. Donc moi je te tire mon chapeau car ça me permet de ressusciter des modules complémentaires ( stop au franglais ! ) que j’avais dû abandonner !

  • karismatik dit :

    Au secours je suis passer a Waterfox ,64 bits oblige.
    j’ai beau modifier le fichier , j’ai un message corrup file ?
    je l’est modifier avec ubuntu exactement comme indiqué!
    ou si j’essai d’installer a partir d’addon ce n’est pas compatible…

    Si’il vous plait je ne retrouverais jamais mon Cooliris avec Firfox 64 bits??

  • Shirozawa dit :

    @karismatik : il faut supprimer le dossier META-INF

Laisser un commentaire

Blog en pause
pause
Traducteur
    Translate to:

Catégories
Archives
Tout ouvrir | Tout fermer
Réseaux Sociaux

 

L’April

Top Blogs Ebuzzing

Wikio - Top des blogs - Logiciels libres